Jump to content

Leaderboard


Popular Content

Showing content with the highest reputation on 10/31/2018 in all areas

  1. 1 point
    Export Products Export products generate's a CSV file which will match the Prestashop import functionality. This allows you to quickly make bulk changes to your store with minimal effort. Features Export all products Export by-products by category. CSV delimiter - lets you set the delimiter of the CSV export. Choose to export only active items. Language select. Only export products in your desired language. Multistore Support. Advanced Stock Management Support. Adds a link to your admin menu for ease of use. (You no longer have to dig through the modules page to use this). To use the module after install, navigate to the following: "Advanced Parameters > Export Products" exportproducts-2.7.1.zip I've also released a Pro version of this module which will export product combinations, categories, addresses & customers. You can read more about it here CHANGE LOG UPDATED v2.7.1 (13/07/2020) - Small fixes for 1.7+ prestashop UPDATED v2.7.0 (25/05/2020) - Include new fields for the latest version of PrestaShop. - Fix line endings.
  2. 1 point
    Duplicate content is something that search engine robots don't like. To avoid it, it's recommended to add canonical links in the header of your shop. It's also good to: direct robots to other language versions of your shop with hreflang links help them navigate through paginated content with prev and next links prevent them from indexing unnecessary parts of the shop with noindex tag To achieve all this, we combined some of the common solutions into one handy free module. You can download the module directly here: gmseofields.zip or from this location (module is for prestashop version 1.6, newer version has canonical tags already partially implemented, so maybe other are coming soon)
  3. 1 point
    Well it depends from theme, it could be maybe in header.tpl or product.tpl. Also it can be some CSS styles that can be entered from back office, like theme configuration maybe and display it "hooked" in header. All these are bad solution and code should be in product.css.
  4. 1 point
    Verificou o log de erros do php? Normalmente em hospedagens Cpanel essa opção é ativa e gera um arquivo chamado "error_log" na raiz da loja e outro dentro da pasta do painel de administração da loja. Verifique se este arquivo foi gerado e leia o log do arquivo que está dentro da pasta do painel administrativo. Caso contrário, solicite ajuda ao suporte de sua hospedagem para a leitura do erro.
  5. 1 point
  6. 1 point
    Hello: Check the results at developer console of the ajax request made by searching module. Try to chance language of your shop and try again. Maybe products has no data in the language you are searching or the search index needs to be regenerated in back office. Regards
  7. 1 point
    Depuis que je connais Prestashop, il y eu une seule mise à jour concernant un problème de sécurité et c'était sur une version 1.4. Oui Prestashop est un cms très particulier. Par son code et la stratégie actuelle. Leur gros problème ce sont les tests, ils nous disent qu'ils en font, ok mais ils les font juste sur leur boutique de test avec John Doe comme seul client, 4 robes et 10 pauvres modules installés. Leur réponse est toujours la même: "On ne peut pas tester toutes les configurations". Et c'est là que le bas blesse, perso à chaque mise à jour, je commence par faire un diff avant de cliquer sur ce bouton sans réfléchir, parce que rien que le changelog c'est minimaliste et ça ne reflète pas les réels changements effectués. Correction d'un bug ? Ok, je vais voir ce qu'ils ont fait et si le bug est vraiment résolu. Ajout d'une feature ? Alors là, attention parce que généralement ça veut dire nouveaux bugs ou pas géré suivant tous les cas de figure. Ensuite, mes boutiques de test on des bases de 2 à 8000 clients en moyenne, des tas de règles paniers et prix spécifique, des configurations multi-langues et des catalogues de + de 10 000 produits. A ça on peut ajouter entre 2 et 300 modules installés. Là je considère que les tests commencent à être représentatifs. Oui Prestashop est responsable en annonçant comme fiable une version qui ne l'est pas Oui Prestashop est responsable en ne mettant en avant que cette version 1.7 et en dissimulant bien les autres (Pour info, la dernière maj de la 1.6 (1.6.1.20) date de moins de 15 jours, alors parler d'ancienne version me fait doucement rigoler) Oui Prestashop depuis 2 ans ne mise plus que sur l'aspect RENTABLE et FINANCIER de sa solution. Exit le côté communautaire, exit la fiabilité, exit les remontées utilisateurs. ils sont les meilleurs et n'écoutent plus leurs clients. Si vous voulez leur parler, ils sont planqués là: - http://build.prestashop.com/ - https://gitter.im/PrestaShop/General - http://forge.prestashop.com/ Bien sûr, vous devez écrire en anglais, sinon passez votre chemin... Symfony, on l'avait réclamé en 2011/2012 et on nous avait répondu à l'époque que le code maison de Presta était très bien comme il était et que ce n'était pas à l'ordre du jour. Smarty fonctionne bien nativement, le problème c'est que Prestashop en a tellement trituré le code que c'est devenu n'importe quoi au niveau de la gestion du cache et que les serveurs passent plus de temps à l'effacer / ré-écrire plutôt qu'à l'utiliser. (Je ne parle même pas de l'option débile d'écrire ce cache en bdd qui plante le moindre mutu...) Suite à la pression des investisseurs et de certains devs, Prestashop a décidé de passer sous Symfony pour plusieurs raisons: - Le code devenait difficile à maintenir (Ben oui, les employés actuels sont tous là depuis peu et maîtrisent très mal les 300 000 lignes de code maison) donc en passant par un framework relativement connu ce sera plus simple. - Ils espèrent faire revenir les développeurs externes vers Prestashop (modules, thèmes et GitHub) - Prestashop donne l'impression d'être à jour et dans la course Mais là encore, on fait ça à la sauce Prestashop, c'est à dire par morceaux tenus par du scotch pour que ça pète pas trop. Passer à Symfony c'est une bonne idée, oui mais leurs modules et thèmes vendus sur Addons ne sont pas compatibles (écrits pour Smarty) et ils n'ont pas le temps ni le personnel pour les mettre à jour, donc s'ils veulent continuer à les vendre, il faut conserver Smarty en parallèle. Et voilà comment on commence les conneries... La 1.7 c'est une 1.6.0.10 à la base qui utilise 2 moteurs de templates (un inédit dans le monde du CMS quand même !) et à laquelle on a supprimé tout ce qui ne marchait pas (on verra au fur et à mesure pour les remettre ou pas, mais l'objectif actuel semble plutôt se tourner vers le remplacement de ces fonctionnalités par des modules payants) Mais plutôt de ré-écrire Prestashop pour être conforme avec Symfony, ils ont rajouté une couche de compatibilité ce qui alourdit encore plus le code et crée une véritable usine à gaz. Et j'ai lu dernièrement qu'ils allaient encore en rajouter une couche pour que nous puissions continuer à écrire le code comme pour les 1.6 (Vu qu'ils peinent à donner envie aux devs externes d'utiliser leur 1.7 bancale). Alors oui, je suis désolé pour vos mésaventures, mais je ne peux pas vous encourager à continuer avec cette version uniquement parce que le nouveau principe de templates est sympa. C'est l'arbre qui cache la forêt et c'est le jour où vous allez vouloir utiliser Prestashop dans ses fonctions avancées que vous aller commencer à galérer sévère (Taxes, prix spécifiques, déclinaisons, transporteurs, stocks avancés, etc...) La 1.7 soit-disante "stable" c'est une version hybride dont les tests sont effectués sur votre dos et sans aucune assistance, et ça, c'est juste une honte.
  8. 1 point
    Prawda w oczy kole boś się pan rozzłościł Uwielbiam Stanowisko google odnośnie pozycjonowania jest jedno- nie wolno sztucznie wpływać na wyniki wyszukiwania. Ale pokazują też drogowskaz- co robić aby nie wpływać negatywnie na wyniki wyszukiwania. Odnośnie prawa- to prawo google. google.pl to ich wyszukiwarka, ogólnie 99% jest Ich. Albo będziesz się stosował do Ich wskazówek- i nie ucierpisz- albo jak piskorz będziesz się wił między definicjami, zasadami i może to trwać kilka miodnych lat, ale może być tak, że jakaś panda, pingwin czy inny Skwronek Cię trafi i zablokuje, wtedy też następuje "rak" i wycofywanie się z obietnic. Nie znam umowy, gdzie umowa działa w równej mierze na jedną i druga stronę:) Zawsze jest po stronie firmy. Przedstaw Swoją umowę którą serwujesz Fajnie dać umowę do podpisania w której nie ma nic o filtrach, banach i innych kwiatkach Klient nieświadomy ( bo przecież nie musi się znać na wszystkim a udał się do fachowca eksperta licząc na uczciwość ) podpisuje, i na tej podstawie masz go pan w sidłach Strona ląduje w kleszczach google- a w umowie nie ma żadnej adnotacji nt. filtra Po to są te Wasze umowy Jedyne to pewnik, że: - trzeba płacić abonament, - płacisz za wynik ( ale o negatywnym wyniku nic nie ma:) ) wszak nie po to przyszedł klient - propozycja marnych fraz kluczowych co klientowi nic nie mówi- on ufa "pozycjonerowi" Pokaż gość umowę i omówimy ją, ja zadam pytania- Ty na nie odpowiesz na forum i zobaczymy czy masz uczciwą umowę Jeśli masz uczciwą- to wyślę do Ciebie tabuny osób szukających pomocy Inaczej milcz waść, obraź się, cokolwiek Ale kit i kapelusze to wiadomo kto wciska
  9. 1 point
    Please open whatsapp.php add function install $this->registerHook('rightColumn') And goto public function hookDisplayFooter() Change public function hookRightColumn()
  10. 1 point
    Hi! I was hoping someone could help me out regarding the 1-Click Upgrade module in the control panel. I am now running Prestashop version 1.6.1.10 and would like to upgrade to the latest 1.6 version, which is 1.6.1.12. When I login to the control panel and go to the 1-Click Upgrade page, I am only presented with the choice to upgrade to version 1.7, no suggestion about the latest 1.6 version at all? How may I solve this? Is it something wrong with the 1-Click Upgrade module? Can I upgrade to 1.6.1.12 by uploading the zip archive to the ftp and set the 1-Click Upgrade to update through archive or folder? Many thanks in advance. Best regards, Jonathan
  11. 1 point
    It worked like a charm with the older module, thanks a lot! Best regards,
  12. 1 point
    prestashop /themes /tu tema /css /modules /blockcart.css
  13. 1 point
    Pour ceux à qui le problème persiste, comme moi, il faut : - Editer le fichier /racine_de_votre_boutique/config/settings.inc.php et modifier define('_PS_CACHE_ENABLED_', '0'); (Bien mettre zéro). - Si possible, redémarrer le serveur apache2 Pour ma part ça a marché. Config : Prestashop 1.5.3.1 sur Serveur dédié
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More