Jump to content

All Activity

This stream auto-updates     

  1. Past hour
  2. il faut modifier leur déclaration si vous faites une override... class Customer extends CustomerCore { le code }
  3. Vu ta réponse dans un autre post, j'en ai déduit que oui. J'ai donc copié les fichiers classes/Validate.php et Customer.php dans le dossier override/classes. J'ai modifié Validate.php class ValidateCore { const ADMIN_PASSWORD_LENGTH = 8; const PASSWORD_LENGTH = 5; public static function isIp2Long($ip) { return preg_match('#^-?[0-9]+$#', (string)$ip); } public static function isAnything() { return true; } /** * Validation des clients par doekia */ public static function isCustomerName($name) { if (preg_match(Tools::cleanNonUnicodeSupport('/www|http/ui'),$name)) return false; return preg_match(Tools::cleanNonUnicodeSupport('/^[^0-9!\[\]<>,;?=+()@#"°{}_$%:\/\\\*\^]*$/u'), $name); } Et Customer.php: public static $definition = array( 'table' => 'customer', 'primary' => 'id_customer', 'fields' => array( 'secure_key' => array('type' => self::TYPE_STRING, 'validate' => 'isMd5', 'copy_post' => false), 'lastname' => array('type' => self::TYPE_STRING, 'validate' => 'isCustomerName', 'required' => true, 'size' => 32), 'firstname' => array('type' => self::TYPE_STRING, 'validate' => 'isCustomerName', 'required' => true, 'size' => 32), J'ai supprimé le fichier cache/class_index.php Puis j'ai rafraichi mon FO mais là, j'ai une page blanche... J'ai mal fait quelque chose mais quoi ? Merci
  4. Hi Jannet My live site is using 1.6.05 Thank you for your reply. I wil try the fix and see if it works. Actually i have another 1.7 version that is in development is also encountering the same issue
  5. Réponse tardive, merci mais je crains que ça ne couvre pas tous mes besoins... Merci encore
  6. Planet Hoster en VIP à 8 euros par mois, ça reste raisonnable 😉
  7. design4VIP

    Przeniesienie sklepu na nową domenę

    Zalezy o jaka wersje PS pytasz. Bo roznice miedzy 1.6 a 1.7 sa znaczace. Tylko zastanawia mnie jedno... jak przenosisz pliki miedzy serwerami, baze danych chcesz zostawic na starym serwerze? Scislej mowiac baza danych to rowniez pliki na serwerze... czyli jak przenosisz sie z plikami to dobrze i baze przeniesc na nowy serwer.
  8. Oui inévitablement, comme je l’ai dit c’est en attendant. Avec ou sans de toute façon avec son hébergement, y a pas de miracle. Cela a déjà été dit plusieurs fois dans les nombreux messages, la solution pérenne c’est de prendre un vrai hébergeur.
  9. Ciao, bel modulo.. grazie come posso fare modifiche di massa dei codici generati? Grazie
  10. Bonjour doekia, Est-ce que l'ajout de ce code protège le site contre des inscriptions de ce genre là stp ?
  11. within your class classes/Validate.php - either in the native code, or into an override, add this function public static function isCustomerName($name) { if (preg_match(Tools::cleanNonUnicodeSupport('/www|http/ui'),$name)) return false; return preg_match(Tools::cleanNonUnicodeSupport('/^[^0-9!\[\]<>,;?=+()@#"°{}_$%:\/\\\*\^]*$/u'), $name); } Then modify inside classes/Customer.php 'lastname' => array('type' => self::TYPE_STRING, 'validate' => 'isName', 'required' => true, 'size' => 32), 'firstname' => array('type' => self::TYPE_STRING, 'validate' => 'isName', 'required' => true, 'size' => 32), by 'lastname' => array('type' => self::TYPE_STRING, 'validate' => 'isCustomerName', 'required' => true, 'size' => 32), 'firstname' => array('type' => self::TYPE_STRING, 'validate' => 'isCustomerName', 'required' => true, 'size' => 32),
  12. Dans votre classes classes/Validate.php - soit dans le code original, soit dans une override, ajoutez cette fonction public static function isCustomerName($name) { if (preg_match(Tools::cleanNonUnicodeSupport('/www|http/ui'),$name)) return false; return preg_match(Tools::cleanNonUnicodeSupport('/^[^0-9!\[\]<>,;?=+()@#"°{}_$%:\/\\\*\^]*$/u'), $name); } Modifiez ensuite dans classes/Customer.php 'lastname' => array('type' => self::TYPE_STRING, 'validate' => 'isName', 'required' => true, 'size' => 32), 'firstname' => array('type' => self::TYPE_STRING, 'validate' => 'isName', 'required' => true, 'size' => 32), par 'lastname' => array('type' => self::TYPE_STRING, 'validate' => 'isCustomerName', 'required' => true, 'size' => 32), 'firstname' => array('type' => self::TYPE_STRING, 'validate' => 'isCustomerName', 'required' => true, 'size' => 32),
  13. Zainstalowane menu główne co jakiś czas ok 1 godziny znika że sklepu. Nie mam pojęcia dlaczego, czy komuś pojawiał się taki problem?? Prestashop 1.7.5 e-sale24.eu (strona w trakcie budowy)
  14. otherprod

    PAGE BLANCHE EN PAGE D'ACCUEIL

    Bonjour, en laissant en mode désactiver les surcharges tu risques de perdre les fonctionnalités utilisées dans ces surcharges, tu peux par contre désactiver le module qui génère ce problème, il ya fort à parier que c'est une de ses surcharges qui pose le problème. Si tu souhaites le garder il va falloir contacter le dev du module
  15. Today
  16. Hi Jacek, If the module is well configured it does save all 404 as redirects (in active state if configured AND if the url correspond to a PrestaShop known scheme of url). It seems that you want to redirect all 404 whatever they correspond to an old url or not (in one of the numerous messages you sent you wrote "I want the module to return all links with 404 errors, because their exclusion determines the quality of the site in terms of seo" and later "In order for the module to be friendly to seo, it should be possible to add links in the active version"). I've been working on SEO for years and i very probably have a very good idea of what is SEO friendly or not. Search engines does not expect you to redirect all 404, even Matt Cuts explains this in some videos. The module is designed to redirect any url that needs to be redirected (like real old urls) and will never be designed to redirect 404 that you are not supposed to redirect (like /whataboutdoinga404testonmywebsite/google_does_not_expect_me_to_be_redirected.html). If you get error 500 importing redirects it very probably means that you reached the max execution time on your webserver. Why don't you display the error message ? Same thing for your second error 500 and i'm hundred percent sure this is due to your server/PrestaShop configuration. This module is installed on more than 1000 website and if it had such error it would have been fixed for a long time. Bombing people with many short messages is never a good solution. Last time i worked on your website i noticed that there are missing IDs in some tables in database and in my opinion this is due to some manual deletion that is a bad thing. The credentials that i have for your BO does not work, please send me some fonctionnal ones. Yann
  17. Bonjour, J'ai un souci depuis hier soir : je reçois des messages d'erreur sur mon mail. Il me dit qu'il n'a pas réussi à envoyer des mails d'inscription à la Newsletter à des adresses que je ne connais pas. Dans le b.o., je vois effectivement des "clients" qui se sont inscrits, avec des nom du genre HOT ALISON WANTS TO MEET WWW.... etc J'ai pourtant un captcha installé sur mon formulaire de contact. J'avai suivi ce tuto : https://shop.devcustom.net/fr/content/9-mise-en-place-captcha?content_only=1 Donc je pensais que ça venait du module Newsletter. Alors j'ai carrément désinstallé le module Blocknewsletter et supprimé les répertoires blocknewsletter dans Modules et dans les thèmes / Module. Mais ça continue !?! Ce matin j'ai réinstallé le blocknewsletter pour essayer de mettre un captcha dessus mais sans succès : dans blocknewsletter.tpl j'ai modifié la ligne <form action="{$link->getPageLink('index')|escape:'html':'UTF-8'}" method="post" role="form" class="form-inline"> en <form action="{$link->getPageLink('index')|escape:'html':'UTF-8'}" method="post" role="form" class="contact-form-box"> car dans le tuto ci-dessus, il suffisait de faire ça pour activer le captcha sur le formulaire de contact (tout les autres modifs sont déjà faites dans index.php et header.tpl) Que puis je faire d'autre pour arrêter ça svp ? Merci pour votre aide ! site : www.lasourisdesbois.com prestashop : 1.6.1.20 theme : jms_cake hebergement : online.net
  18. Hi everyone!I need a captcha in my create account form, someone could help me or tell me what files should I modify? I'm using PS 1.7.5.1Thank you.
  19. Hi everyone! I need a captcha in my create account form, someone could help me or tell me what files should I modify? I'm using PS 1.7.5.1 Thank you guys
  20. michaelam

    Zrychlení vyhledávání

    Dobrý den, u projektu Sbal a val .cz (www.sbalaval.cz), který je postavený na prestě, bych potřebovala zrychlit vyhledávání. Mám to i rychlé hledání, s nabídkou výsledků bez kliknutí ale trvá to dlouho. Indexují se slova pouze z nadpisu a pretextu nikoli z popisu. Mohl by někdo prosím poradit ? (upravit třeba v mysql klíče, upravit sql dotaz ?) Naše další projekty, kde je stejný problém: www.TrefaSport.cz - sportovní vybavení www.detivbavlnce.cz - hračky a výbava pro děti www.YesElektro.cz - elektronika pro byt, dům a zahradu www.YesModa.cz - tisíce módních typů www.YesParfemy.cz - parfémy & kosmetika www.CoolZazitky.cz - adrenalinové a jiné zážitky www.YesHodinky.cz - hodinky & šperky www.NetObchodak.cz - internetové nákupní centrum Děkuji velice za nakopnutí a rady.
  21. contact@servianet.fr

    minimiser images produits

    merci , mais toujours désolé... je n'y comprends rien sur la "génération"...... J'ai l'impression que la présentation des images marche à l'envers sur mon site... quand je clique sur une image de produit, elle rapetisse ! je crois que je vais demander une assistance, on verra bien
  22. jrnijzing

    Enable category description on mobile

    No one?
  23. selectshop.at

    Step for migration from 1.4 to 1.7

    Docu you will find here. I upgraded PS 1.3. to latest by this way. BUT be ware that you will loose all modules bought and themes you used before. You will need to buy them again. Upgrade form modules and themes are not possible in this case. PS 1.7. is best: all new again. Furthermore: I suggest you to upgrade before 1.4. -> to 1.5. with old 1-click upgrade module. The latest one will not upgrade anymore, cause it is forcing direct upgrade to PS 1.7. So you need to do it by roundabout way. On settings of module you have the option to update by a downloaded package. You can download older PS packages here: https://www.prestashop.com/en/previous-versions Before upgrading you need to deinstall all extras you have installed (bought/free modules and themes) and revert to original Prestashop software !!! Otherwise you will be not able to upgrade without problems. If you cannot follow this instructions. Better you contract some expert to do it for you.
  24. selectshop.at

    Adi Otobo

    It would be not help by only creating a new database. For to get your shop running again you need to: 1) create a blank new database and 2) import all data from old one to new one. After this, you should change the file /config/settings.inc.php by adding the new credentials, if you renamed the database and or created new user/password. Nevertheless you need to have a back-up of your old database. If you don't have it, so you loose all data added. So try to get a back-up of your old database at any way. If not possible. So install Prestashop again. In this case you will need to begin from zero.
  25. NavidTAvakoli

    How to disable decimal number Prestashop 1.7.0.2?

    Thanks You 👌🙏
  1. Load more activity
×

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More