Jump to content

All Activity

This stream auto-updates     

  1. Past hour
  2. joseantgv

    TTFB of 25 seconds

    Its not _PS_MODE_DEV_ but _PS_DEBUG_PROFILING_.
  3. Dreamtheme

    Plesk + Nginx, the big forgotten of Prestashop?

    Hi, .htaccess may come with PrestaShop installation (especially if imported from other server). Obviously you did not mention if there is PS Cache turn on (its on by default) or CDN setup. Debug mode on application level can help you point out the direction of what is the server issue. Friendly URL do had problems with translations in the past with PS. But i'm sorry i tried to help good luck.
  4. Hola, En MODULOS>>PAGO>>PAYPAL Al darle al botón de "test", me salta con la frase "TLS version is not compatible" (Imagen) ¿Como se arregla esto? Un saludo
  5. ienabellamy

    TTFB of 25 seconds

    Hi everybody and thanks for answering. i disabled all non default modules and all overrides, nothing changes, so i suppose isn't a module (at least not a third part module) define('_PS_MODE_DEV_', true); did absolutely nothing, nothing appears, no errors showing, nothing. i'm the server admin so i must solve. You say that's a server issue but i have this issue only for PS site, for other sites, like Wordpress or Joomla it's all fine. Nothing changed, please help.
  6. Hi, Check this documentation - https://devdocs.prestashop.com/1.7/themes/getting-started/.
  7. Becquel

    How send a PUT / POST to Webservice API

    Well, as I can see in the first comment of this post I think the problem is in your XML format. Apache is not blocking your request given Apache is not checking your request for XML errors, this is done by your webservices endpoint. So let me tell my procedure to make a POST / PUT and try to reproduce in your server: 1. I make POST to the url https://domain.com/shop/api/customers?ws_key=ABCDEFGHIJKLMNOPQRST123123123 <?xml version="1.0" encoding="UTF-8"?> <prestashop xmlns:xlink="http://www.w3.org/1999/xlink"> <customer> <id_default_group></id_default_group> <id_lang></id_lang> <newsletter_date_add></newsletter_date_add> <ip_registration_newsletter></ip_registration_newsletter> <last_passwd_gen></last_passwd_gen> <secure_key></secure_key> <deleted></deleted> <passwd>123456123</passwd> <lastname>Unknown</lastname> <firstname>Matthew</firstname> <email>matt@mail.com</email> <id_gender></id_gender> <birthday></birthday> <newsletter></newsletter> <optin></optin> <website></website> <company></company> <siret></siret> <ape></ape> <outstanding_allow_amount></outstanding_allow_amount> <show_public_prices></show_public_prices> <id_risk></id_risk> <max_payment_days></max_payment_days> <active></active> <note></note> <is_guest></is_guest> <id_shop></id_shop> <id_shop_group></id_shop_group> <date_add></date_add> <date_upd></date_upd> <reset_password_token></reset_password_token> <reset_password_validity></reset_password_validity> <associations> <groups> <group> <id></id> </group> </groups> </associations> </customer> </prestashop> 2. I make PUT to the url https://domain.com/shop/api/customers/17?ws_key=ABCDEFGHIJKLMNOPQRST123123123 where you have to change the /17 for the id of your new customer. After that add a <id>17</id> at the xml structure and thats all. I also have to say that since I enabled multishop now PUT requests are updating data but disabling the customer given not appear in the backend, for sure is related with some field like active or disabled... Anyway, after adding the id in the URL and in the XML. the body of the request will be the following: <?xml version="1.0" encoding="UTF-8"?> <prestashop xmlns:xlink="http://www.w3.org/1999/xlink"> <customer> <id>17</id> <id_default_group></id_default_group> <id_lang></id_lang> <newsletter_date_add></newsletter_date_add> <ip_registration_newsletter></ip_registration_newsletter> <last_passwd_gen></last_passwd_gen> <secure_key></secure_key> <deleted></deleted> <passwd>123456789</passwd> <lastname>Presta</lastname> <firstname>Presta</firstname> <email>presta@mail.com</email> <id_gender></id_gender> <birthday></birthday> <newsletter></newsletter> <optin></optin> <website></website> <company></company> <siret></siret> <ape></ape> <outstanding_allow_amount></outstanding_allow_amount> <show_public_prices></show_public_prices> <id_risk></id_risk> <max_payment_days></max_payment_days> <active></active> <note></note> <is_guest></is_guest> <id_shop></id_shop> <id_shop_group></id_shop_group> <date_add></date_add> <date_upd></date_upd> <reset_password_token></reset_password_token> <reset_password_validity></reset_password_validity> <associations> <groups> <group> <id></id> </group> </groups> </associations> </customer> </prestashop>
  8. Hi. Hello Obviously in a test facility, there is no CDN, no caches, ... Obviously if we are pulling Nginx there is no .htaccess, and of course if we are talking about the URL Friendly problem, lol, there is no point in deactivating this. As for seeing the debug mode of the application layer, well it may be fine, although I am afraid that the problem is the rule of the server layer. Maybe this concept will escape. Sometimes it's better to keep quiet, than to say useless things Best regards
  9. HI, Thank you for your module. It is working like a charm but I can not set background transparency like @pegtop. I have installed last version 2.0.2. I have tried to modify the css but I set transparency for all window. Anybody know what css class I have to change, please? You can check at hogarterapia.com
  10. Hi! I want to let my guests to see payment methos without sign in. I use one page checkout (One Step Checkout / One Page Checkout v1.6.7 - by best-kit.com) for prestashop 1.6. I tried to edit OrderOpcController.php protected function _assignPayment() { if ((bool)Configuration::get('PS_ADVANCED_PAYMENT_API')) { $this->context->smarty->assign(array( 'HOOK_TOP_PAYMENT' => ($this->isLogged || $this->is_guest ? Hook::exec('displayPaymentTop') : ''), 'HOOK_PAYMENT' => $this->_getPaymentMethods(), 'HOOK_ADVANCED_PAYMENT' => Hook::exec('advancedPaymentOptions', array(), null, true), 'link_conditions' => $this->link_conditions )); } else { $this->context->smarty->assign(array( 'HOOK_TOP_PAYMENT' => ($this->isLogged || $this->is_guest ? Hook::exec('displayPaymentTop') : ''), 'HOOK_PAYMENT' => $this->_getPaymentMethods() )); } } protected function _getPaymentMethods() { if (!$this->isLogged || !$this->is_guest) { return '<p class="warning">'.Tools::displayError('Please sign in to see payment methods.').'</p>'; } but... doesn't work.... Any help? please
  11. Bonjour à tous Qui peut m'aider à résoudre les derniers mixed content qui me reste pour avoir un joli cadenas sur mes page produits? J'en ai viré pas mal mais il en reste Les images de la galerie par exemple ! https://www.jackjamon.fr/gallerie/index.php Presta 1.5.6 merci Pascal
  12. grafistas7

    xml feed bestprice/skroutz

    Τι να σου πω τώρα.. αόριστα...με έχουν κουφάνει... Αν τα 8.000 προιοντα θεωρούνται πολλά.. πεταμένα λεφτά
  13. oj tam oj tam da radę ale no fakt trzeba się znać raz łączyłem bazę z 1.4 do 1.7 a te są całkiem inaczej zbudowane da radę
  14. Dreamtheme

    How to create a custom page without CMS

    The concept of PrestaShop is quite different from WordPress, the native page builder is CMS. With that said, you can try the free or paid third party page builder modules that offer such functionality. I even saw Elementor for PrestaShop
  15. For me problem solved by changing php script memory size in php.ini from 32M to 64M, now the page showing up and woks correctly. Hope this help others.
  16. Dreamtheme

    Product Combination

    PrestaShop build-in product import is very limited and buggy, and if you plan to do this often, i suggest you to find an addon that offers more control over the process and has support - https://addons.prestashop.com/en/451-data-import-export
  17. Bonjour, je suis en 1.7.4.3 quand je fait un copier collé d'un texte dans mon descriptif ou que je l'écris au clavier, cela fonctionne. Par contre quand je fais un copier collé du texte chez mon fournisseur le texte est gris et n'apprêt pas dans le front office. Pourtant au début cela fonctionné et après une 30 aine de fiches produits plus rien. Merci de votre aide.
  18. No, I haven't yet. So this is theme related then..
  19. bu.ka.rol

    Problem z trybem DEV

    Jest tu ktoś kto potrafi udzielić wskazówek?? Pozdrawiam!
  20. I have a prestashop 1.7.5 and i would like to put a registration form on a CMS page. Is there a module for that, or can you help me for do that. Thank Camille
  21. Dreamtheme

    Changing theme's name in back office

    Switch to default theme and disable the theme that you want to change the name. Then change the folder to the name you want and also change the name in your theme folder/config/theme.yml
  22. Dreamtheme

    Product combinations on category page

    Hi, Nope you can't do that. You can edit your theme to display mouse over to different combinations of the product, like different images and things. Why do you want to show the same product as different ones? Even if you figure a way to do it, this is terrible for customer experience and many users will be confused.
  23. Dreamtheme

    Plesk + Nginx, the big forgotten of Prestashop?

    Start by disable the CDN and all caches (Server and PrestaShop), Enable Debug mode on PrestaShop and check what errors it will display for you. Also check PrestaShop logs in Var folder. Furthermore, disable the friendly URL's and delete the .htaccess and you can try to delete the Var/Cache folder (prod or dev or both).
  24. Hev

    Problem z wysyłką - PILNE

    Gdyby ktoś poszukiwał rozwiązania, ten wątek rozwiązał mój problem. Winny jest PHP 7.3
  25. bonjour , j'utilise prestashop 1.7 pour répondre la question posée au début du sujet , j'ai eu le méme probléme, (voir photo juste au dessus) lorsque "le produit est ajouté avec succés " la déclinaison taille ne s'affiche pas j'avais taille S M L XL et j'ai remarqué que ma déclinaison pointure s'affichait avec le mot TAILLE dans le génerateur de déclinaison (pourtant marqué Pointure dans le back office) j'ai supprimé toutes les déclinaisons sauf couleur qui s'affichait correctement et j'ai recréer mes tailles , je conseil d'utiliser l'affichage BOUTON RADIO c'est nettement plus agréable lors de la sélection d'une taille et d'une couleur depuis tout fonctionne , bon courage pour régénérer les déclinaisons supprimées
  1. Load more activity
×

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More