Vote to Improve PrestaShop

PrestaShop Forum: Build a free online shop. Count on the Community!

The best place in the world to ask questions about PrestaShop and get advice from our passionate community!

PrestaShop Forum: Build a free online shop. Count on the Community!

Jump to content

 
Photo

[SOLVED] Features values can't be saved when changed...


  • Please log in to reply
40 replies to this topic
Mike Kranzler

    PrestaShop Superstar

  • Members
  • PipPipPipPipPip
  • 8076 posts

Posted 13 March 2012 - 02:53 PM

I host the server myself, and I am the admin too... I have access to the php.ini, but I couldn't find the max_input_vars in this file. I searched through this file using "nano" in my ubuntu server. Where is this value?


Hi hokaro,
First of all, did you already apply my first suggestion about checking the permissions of your tools/smarty directory?

Additionally, can you please place the attached file in the root of your store, and then navigate to www.yoursite.com/phpinfo.php and search for that max_input_vars value in the results that come up?

Attached File  phpinfo.php   19bytes   232 downloads

-Mike
I am no longer PrestaShop's Community Manager. Please direct all PrestaShop Forum requests to Benjamin Utterback or Patric Codron

hokaro

    PrestaShop Apprentice

  • Members
  • PipPip
  • 38 posts

Posted 13 March 2012 - 07:14 PM

Hi hokaro,
First of all, did you already apply my first suggestion about checking the permissions of your tools/smarty directory?

Additionally, can you please place the attached file in the root of your store, and then navigate to www.yoursite.com/phpinfo.php and search for that max_input_vars value in the results that come up?

Attached File  phpinfo.php   19bytes   232 downloads

-Mike


Thanks for the effort. Yes, I did change the chmod to 655 as you wrote.

I put your file, phpinfo.pho, into my root, and here are some the lines:

log_errors_max_len 1024 1024 magic_quotes_gpc Off Off magic_quotes_runtime Off Off magic_quotes_sybase Off Off mail.add_x_header On On mail.force_extra_parameters no value no value mail.log no value no value max_execution_time 30 30 max_file_uploads 20 20 max_input_nesting_level 64 64 max_input_time 60 60 max_input_vars 1000 1000

As you see, the last line is max_input_vars and it's value is 1000... I guess this should be changed, where can i change it?

hokaro

    PrestaShop Apprentice

  • Members
  • PipPip
  • 38 posts

Posted 13 March 2012 - 07:17 PM

Hi hokaro,
First of all, did you already apply my first suggestion about checking the permissions of your tools/smarty directory?

Additionally, can you please place the attached file in the root of your store, and then navigate to www.yoursite.com/phpinfo.php and search for that max_input_vars value in the results that come up?

Attached File  phpinfo.php   19bytes   232 downloads

-Mike


sorry, I try to paste the above line again, as it was pasted into the box in a bad way. Here is the discussed parameter:

max_input_value: 1000 (local value) .... 1000 (master value)

PS: read my previous post too, please

Mike Kranzler

    PrestaShop Superstar

  • Members
  • PipPipPipPipPip
  • 8076 posts

Posted 13 March 2012 - 07:58 PM

Hi hokaro,
Since you don't seem to have this value in your php.ini file, please back it up and then try adding this line to it:

max_input_vars = 6000

Hopefully, that will allow you to override that error. Please let me know if this works for you.

-Mike
I am no longer PrestaShop's Community Manager. Please direct all PrestaShop Forum requests to Benjamin Utterback or Patric Codron

hokaro

    PrestaShop Apprentice

  • Members
  • PipPip
  • 38 posts

Posted 13 March 2012 - 09:05 PM

I did what you said, and it worked like a charm :) ... now it adds new values and changes old values as it should. Thanks a lot for your help.

I stay a Prestashop:er :)

Mike Kranzler

    PrestaShop Superstar

  • Members
  • PipPipPipPipPip
  • 8076 posts

Posted 13 March 2012 - 09:12 PM

Great, I'm glad I could help, even if it was a little more difficult than we would've liked. I'll go ahead and mark this thread as solved for you. Happy selling!

-Mike
I am no longer PrestaShop's Community Manager. Please direct all PrestaShop Forum requests to Benjamin Utterback or Patric Codron

xEpyonx

    PrestaShop Apprentice

  • Members
  • PipPip
  • 62 posts

Posted 14 March 2012 - 02:38 AM

Hi Hokaro,

I'm really happy this solved it for you! I also ran the phpinfo.php file and also came up with
max_input_vars = 1000

And then I remembered that last month my provider updated the server to php 5.3 and maybe the settings got reset.

I'll mail them tomorrow and see if it's possible for them to set it to 6000 since I probably don't have access to the php.ini file.

Also, Mike, thank you very much for putting in the time and effort to help solve this problem!

Mike Kranzler

    PrestaShop Superstar

  • Members
  • PipPipPipPipPip
  • 8076 posts

Posted 14 March 2012 - 02:33 PM

It's my pleasure! Please let me know if that works for you as well!

-Mike
I am no longer PrestaShop's Community Manager. Please direct all PrestaShop Forum requests to Benjamin Utterback or Patric Codron

xEpyonx

    PrestaShop Apprentice

  • Members
  • PipPip
  • 62 posts

Posted 14 March 2012 - 06:17 PM

Hi Mike,

The solution also worked for me! I used the .htaccess generator in the Prestashop backend to add
php_value max_input_vars 6000
to my .htaccess file to temporarily override the standard value.

Since the problem really is only with the actual saving of the feature values, I delete the line from my .htaccess so the server goes back to it's original setting when I'm done adding features.

My hosting provider also was very helpful in this. They did note that Prestashop really shouldn't need for the max_input_vars to be so high, since it's actually a safety measure of sorts, so maybe this is something that can be addressed in Prestashop v1.5, which I'm really looking forward to by the way!

Still, I'm relieved everything works just fine again!

Mike Kranzler

    PrestaShop Superstar

  • Members
  • PipPipPipPipPip
  • 8076 posts

Posted 14 March 2012 - 07:05 PM

Great, I'm glad this worked for you too! Happy selling!

-Mike
I am no longer PrestaShop's Community Manager. Please direct all PrestaShop Forum requests to Benjamin Utterback or Patric Codron

Frens

    PrestaShop Fanatic

  • Members
  • PipPipPipPip
  • 1600 posts

Posted 19 March 2012 - 03:09 PM

Hi


My hosting provider tell its a high risk.. to set the value high : php_value max_input_vars 6000


'hash collisie' attack,on PHP: http://www.php.net/m....max-input-vars


In the next future , he wil make it impossible to set the value high .


I try to change the Languages in the xx.php file , but there are no change in the translation text !

Leonardoeng

    PrestaShop Newbie

  • Members
  • Pip
  • 3 posts

Posted 21 July 2012 - 08:50 PM

Hi Guys,

I got this issue too ... I had changed the max_input_vars to 6000 and worked fine by two weeks, now I got this issue again. I changed the max to 100000 and persisted the features issue.

Anyone have a different solution?

Bejo

    PrestaShop Apprentice

  • Members
  • PipPip
  • 250 posts

Posted 21 September 2012 - 10:53 AM

how about you create new file php.ini and put it at admin folder root.
on php.ini put this

suhosin.post.max_vars=4252
suhosin.request.max_vars=4252
max_input_vars = 6000



tell me it's work or not.thx

alarmdanmark.dk

    PrestaShop Newbie

  • Members
  • Pip
  • 6 posts

Posted 24 September 2012 - 06:11 PM

how about you create new file php.ini and put it at admin folder root.
on php.ini put this

suhosin.post.max_vars=4252
suhosin.request.max_vars=4252
max_input_vars = 6000



tell me it's work or not.thx


Hi i don't have acces to the server php.ini - but i have the same problem and the host wont set up the max_input_vars limit because he is afraid of DNS attack

does anyone have a solution - i cant use the translation of the shop

dzsar

    PrestaShop Apprentice

  • Members
  • PipPip
  • 48 posts

Posted 26 October 2012 - 06:26 PM

create .htaccess file to domain.com/admin/ folder

.htaccess content:

php_value max_input_vars 10000

or

php_value max_input_vars 6000



paulmparfum

    PrestaShop Newbie

  • Members
  • Pip
  • 17 posts

Posted 28 November 2012 - 09:21 PM

create .htaccess file to domain.com/admin/ folder .htaccess content: or

thank's a lot, work fine
It is very easy to do something complicated, but it is very difficult to do something
simple. :) - Paul
http://costumebaie.eu
http://puzzle-personalizat.eu

amr.rs

    PrestaShop Apprentice

  • Members
  • PipPip
  • 50 posts

Posted 13 December 2012 - 12:49 PM

I also have the same issue. Features are not getting saved. Any help pls? :unsure:
---
Regards,
AMR.

sgtbash

    PrestaShop Apprentice

  • Members
  • PipPip
  • 116 posts

Posted 23 January 2013 - 05:37 PM

Fixed for me by placing
max_input_vars = 6000

in a new file "php.ini" inside my 'admin' folder.

=)

The .htaccess version of this did not work for me. Must be differences in server set ups as my host allows override php.ini files to be made.

=)

imadnl

    PrestaShop Newbie

  • Members
  • Pip
  • 1 posts

Posted 14 April 2013 - 12:49 AM

I don't know how to do that, can you send me a sample file how i have to paste "max_input_vars =6000"?

jrok

    PrestaShop Newbie

  • Members
  • Pip
  • 4 posts

Posted 27 April 2013 - 08:32 PM

HI I JUST SOLVED!!!

THE PRODUCT MUST HAVE SOME PROBLEM IN UPC OR EAN13 OR META OR SEO...THATS WHY CANT BE SAVED. AFTER THAT FEATURES WORK AGAIN.

Edited by jrok, 27 April 2013 - 08:48 PM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users