PrestaShop Forum: Build a free online shop. Count on the Community!

The best place in the world to ask questions about PrestaShop and get advice from our passionate community!

PrestaShop Forum: Build a free online shop. Count on the Community!

Jump to content

 
Photo

Canada Post Shipping Module Issue

shipping module 0.1 Canada

  • Please log in to reply
6 replies to this topic
Ardshael

    PrestaShop Newbie

  • Members
  • Pip
  • 17 posts

Posted 14 October 2011 - 07:48 PM

Is anyone using the Canada Post Carrier Shipping Module v0.1?

I'm trying to use it but I'm getting an error:

Posted ImageCanada Post Carrier is not configured yet, you must:
Posted Image 1) Fill the "General Settings" form
Posted Image 2) Select your available delivery service
Posted Image 3) Webservice test connection : Error -2001 : Merchant CPC Id not found on server.
Posted Image 4) cURL is enabled

I have set up an account with Canada Post and as far as I know, I have the right ID in so I'm not sure what the error is exactly. Can anyone help?

Ardshael

    PrestaShop Newbie

  • Members
  • Pip
  • 17 posts

Posted 17 October 2011 - 07:48 PM

Ok, I figured out the module. For those that may have the same problem, here's the solution.

You Canada Post account isn't what you put into the module. You need to create a SellOnline account as well. More information here: http://www.canadapost.ca/sellonline

Then you will email sellonline@canadapost.ca the following information:

COMPANY NAME (SAME NAME USED ON THE CPC CONTRACT):
FULL BUSINESS ADDRESS:
MAIN CONTACT ( FULL NAME ):
TELEPHONE NUMBER (WITH AREA CODE):
GENERAL BUSINESS E-MAIL ADDRESS:
CUSTOMER/VENTURE ONE NUMBER:
CONTRACT NUMBER (NOT REQUIRED FOR VENTURE ONE CUSTOMER):

To get the Customer and Contact numbers your customer would have to contact
the Commercial Service Network @1-800-260-7678

They will then send you a user name starting with CPC_ and that is what you put into the module. Hopefully that helps someone else.

Cheers,
Clinton

BadgerDog

    PrestaShop Apprentice

  • Members
  • PipPip
  • 67 posts

Posted 08 December 2011 - 06:43 PM

Hi .. :)

I'm confused with that site ...

Do I have to pay $25-$30/month to one of those commercial vendors to have PrestaShop Canada Post module to be able to work?

Regards,
Doug

WhitePhoenix

    PrestaShop Newbie

  • Members
  • Pip
  • 7 posts

Posted 09 December 2011 - 09:23 PM

Hi,

Email: sellonline@canadapost.ca

They will send you an email back, you will most likely have to call them to set up an account which is FREE.

You don't need to buy any of the packages from the commercial guys, just use the module that comes with Prestashop.

Regards,

Russ
White Phoenix - Spiritual and Mental Healing
http://www.whitephoenix.ca @WhitePhoenixSH

BadgerDog

    PrestaShop Apprentice

  • Members
  • PipPip
  • 67 posts

Posted 09 December 2011 - 11:53 PM

Thank you Russ ... :)

I followed your advice and got an account, configured it and the gateway went live with no errors.

Are you actually using Canada Post and this module for shipping?

I ask because I've been doing some testing with it and I find it does some really strange things....

I set up 3 items with identical package weights, lengths, widths and heights.

Here's what I found when I try to add these items to the CART and have the Canada Post module calculate shipping.

1. It doesn't work at all if I select "split one item per package" method. No shipping costs are ever added to any of the three items. Just left at $0 and no carrier shows up.

2. If I switch to "all items in one package", then when I add one item to the cart, it adds a shipping charge. When it gets to the shipping page, it shows me which Canada Post service it selected, but note how screwed up the rates are (see pic). REGULAR is 4 days and EXPEDITED is 1 day for the SAME price. :blink:

3. Even though all 3 items I'm testing have identical specs, on 2 of them only the REGULAR Canada Post service for $25.36 shows up, whereas on 1 of the items, the 3 service levels shown in the pic attached appear. :rolleyes: With absolutely no difference between all 3 items, any idea how this is possible?

4. Finally, even set with "all items in one package" here's something even stranger. I add 1 item to the cart and the shipping REGULAR shipping rate shows up. I add a second item and the shipping rate changes to $0. When I get to the shipping screen, NO Canada Post services show up at all. :huh:

Anyway, I'm not sure this module is ready for prime time, or I'm doing something wrong in using it, or misunderstanding how to use it?

With no other shipper available to me in Canada to use and PrestaShop doesn't permit one to bypass the shipper screen without crashing if no shippers are specified (see other help post I made on that subject), I'm not sure we'll be able to use PrestaShop for our on-line store solution. :(

Appreciate your help in getting us live with Canada Post. I see you're just down the road from us. We're on Toronto and I was born and raised in London, some 64 years ago. :lol:

Regards,
Doug

Attached Files



sweetisabelle

    PrestaShop Newbie

  • Members
  • Pip
  • 16 posts

Posted 10 December 2011 - 05:05 AM

Actually, when you set up a corporate account with Canada Post, it gives you automatically the 1 day rate at the rate of the 4 days... Don't ask... (I think everyone should have a corporate account then...). So that might answer some of you questions...

BadgerDog

    PrestaShop Apprentice

  • Members
  • PipPip
  • 67 posts

Posted 10 December 2011 - 12:33 PM

Thank you sweetisabelle ... :)

At least that explains one anomaly of the PrestaShop Canada Post shipping module. I guess I should eliminate the "Regular" shipping service from the module's use as it's just confusing to customers.

Although, as you can see from the pic, it's showing a service option for Priority Courier and that one is not checked on the Canada Post shipping module to be offered, so I'm not sure un-checking "Regular" will make any difference as I don't think the module, or its interaction with Canada Post's webs ite is working properly.

Appreciate the help ..

Regards,
Doug




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users