Vote to Improve PrestaShop

PrestaShop Forum: Build a free online shop. Count on the Community!

The best place in the world to ask questions about PrestaShop and get advice from our passionate community!

PrestaShop Forum: Build a free online shop. Count on the Community!

Jump to content

Photo

Paypal Error (Cannot complete payment)


  • Please log in to reply
29 replies to this topic
ridvan

    PrestaShop Newbie

  • Members
  • Pip
  • 1 posts

Posted 31 March 2011 - 02:52 PM

Hello There,

I'm getting on error when i try to checkout with paypal,
here is the errorr message:
PayPal response:
TIMESTAMP -> 2011-03-31T15:21:19Z
L_ERRORCODE0 -> 10002
L_SHORTMESSAGE0 -> Security error
L_LONGMESSAGE0 -> Security header is not valid
L_SEVERITYCODE0 -> Error
PayPal returned error

Already tried, to delete API and create new one, but that didn't help :(

Pleaseeee help :(

hawaii350

    PrestaShop Apprentice

  • Members
  • PipPip
  • 54 posts

Posted 07 April 2011 - 03:22 AM

Having the same problem :(

hawaii350

    PrestaShop Apprentice

  • Members
  • PipPip
  • 54 posts

Posted 07 April 2011 - 03:50 AM

For what ever reason copying and pasting the api password does not work. It shows up with stars and the correct length but results in that error. Finally I tried typing it by hand and it works.

theme_designer

    PrestaShop Apprentice

  • Members
  • PipPip
  • 386 posts

Posted 07 April 2011 - 06:59 AM

Yes, manually typing it can make it work.

Starting a web project from a website template.


soggy moggie

    PrestaShop Newbie

  • Members
  • Pip
  • 7 posts

Posted 07 April 2011 - 07:10 AM

Im getting the same problem

PayPal response:
TIMESTAMP -> 2011-04-07T08:10:31Z
L_ERRORCODE0 -> 10002
L_SHORTMESSAGE0 -> Security error
L_LONGMESSAGE0 -> Security header is not valid
L_SEVERITYCODE0 -> Error
PayPal returned error

fyswan1

pluto26

    PrestaShop Newbie

  • Members
  • Pip
  • 12 posts

Posted 08 April 2011 - 02:02 AM

I am getting teh exact same error.

I tried re-entering the password a numbe rof times, same error

PayPal response:
TIMESTAMP -> 2011-04-08T03:05:57Z
L_ERRORCODE0 -> 10002
L_SHORTMESSAGE0 -> Security error
L_LONGMESSAGE0 -> Security header is not valid
L_SEVERITYCODE0 -> Error
PayPal returned error


has anyone fund a fix for this?

Thanks

riga

    PrestaShop Newbie

  • Members
  • Pip
  • 21 posts

Posted 08 April 2011 - 11:07 AM

I have also the same error :(

Merci de vous reférer aux logs :
PayPal response:
TIMESTAMP -> 2011-04-08T12:11:37Z
L_ERRORCODE0 -> 10002
L_SHORTMESSAGE0 -> Security error
L_LONGMESSAGE0 -> Security header is not valid
L_SEVERITYCODE0 -> Error
PayPal a retourné une erreur

chup

    PrestaShop Apprentice

  • Members
  • PipPip
  • 85 posts

Posted 11 April 2011 - 04:01 AM

me too, same error :(

chup

    PrestaShop Apprentice

  • Members
  • PipPip
  • 85 posts

Posted 11 April 2011 - 04:08 AM

we had tried requesting a new API, manually key in the password, still didn't resolve the issue

salesfromisrael

    PrestaShop Newbie

  • Members
  • Pip
  • 20 posts

Posted 11 April 2011 - 04:51 AM

I am also getting paypal errors. when i click onthe paypalbox i get a 404

ddoan2007

    PrestaShop Newbie

  • Members
  • Pip
  • 21 posts

Posted 12 April 2011 - 05:27 AM

Just do what it says, leave the API password blank if it has not changed. It works for me. Hope that helps.

han08

    PrestaShop Newbie

  • Members
  • Pip
  • 4 posts

Posted 12 April 2011 - 05:56 AM

I have a same problem
payp error presta1.4
www.clickerwholesale.com

chup

    PrestaShop Apprentice

  • Members
  • PipPip
  • 85 posts

Posted 13 April 2011 - 03:43 PM

any moderator or admin on a firm solution on this?

madmike

    PrestaShop Apprentice

  • Members
  • PipPip
  • 128 posts

Posted 16 April 2011 - 07:38 AM

Same problemeon 1.4.0.17 :
L_LONGMESSAGE0 -> Security header is not valid

Try all type of correctoion found in forum : recreate api key, use default theme, handwrite code .

chup

    PrestaShop Apprentice

  • Members
  • PipPip
  • 85 posts

Posted 16 April 2011 - 08:49 AM

it say this is not a bug here

http://forge.prestas...owse/PSCFI-1142

but there seem like alot of people (including me) can't configure properly to make it work at all

madmike

    PrestaShop Apprentice

  • Members
  • PipPip
  • 128 posts

Posted 16 April 2011 - 11:30 AM

I uncheck the sandbox mode and now it work

tomcat80

    PrestaShop Apprentice

  • Members
  • PipPip
  • 35 posts

Posted 17 April 2011 - 09:11 AM

I uncheck the sandbox mode and now it work



Thanks, it works for me now!
I typed manualy the password, unchecked ths sand mode and now its working.

chup

    PrestaShop Apprentice

  • Members
  • PipPip
  • 85 posts

Posted 18 April 2011 - 12:22 PM

hope they look at it soon.

not a small bug in my opinion if we cannot do testing on the most popular payment module

madmike

    PrestaShop Apprentice

  • Members
  • PipPip
  • 128 posts

Posted 18 April 2011 - 11:09 AM

uncheck the sandbox button seem to solve the problem, but in this case how do we test the transaction?



Good question lol ! This is a bug ;-) > http://forge.prestas...owse/PSCFI-1504

chup

    PrestaShop Apprentice

  • Members
  • PipPip
  • 85 posts

Posted 18 April 2011 - 10:22 AM

uncheck the sandbox button seem to solve the problem, but in this case how do we test the transaction?




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users